Update doesn't install

Fsh_Fsh_ Posts: 4
Hi,
Since about 2 months I'm unable to update Candy Crush Saga.
I play on a Sony, android 7.1.1. The update from Google play downloads, but doesn't install. Instead, the download starts over and over again.

What I've tried so far:
- First I thought it was a bug, so I waited for the next update... and the next... But still, same issue.
- I've cleared the cache from Candy Crush and the data and cache from the Google play app and restarted my phone. Didn't help.
- I checked the available storage on my phone, there's enough.
- Other apps can update, no problems there.
- I've tried downloading the updates while connected to wifi, then to 4G. It made no difference.

I recorded my screen so you can see what happens: https://vimeo.com/360229004

Any ideas on what might be the issue here?

Answers

  • tsaytdstsaytds Posts: 75 ✭✭✭
    edited September 16
    Hi, previous edition was for reinstallation of the app.I realize you are looking for update problem,  There only can be either play store or CCS app is corrupted. Play store is more likely. Check website, there are lots information. 
  • Fsh_Fsh_ Posts: 4
    What website? I couldn't find any related topics on this community. Do you have a link?
  • Sukanta_BiswasSukanta_Biswas Posts: 8,568 Superstar
    Hi @Fsh_
    Welcome, and thank you for becoming a member of the King Community! I will be very happy if I can help you.😊

    Perhaps your Google play store has a setting set incorrectly, so this is a problem. Follow the steps below👇
    Open Google Play store > Setting > App download preference > Over any network > Done> back <
    Auto update apps > Over any network > Done

    Even if the problem is not resolved.

    The Google Play Store relies on other processes that run silently in the background. Whenever you wipe the Play Store, it’s also a good idea to do the same with Google Play services and Google Services Framework. Optionally, you may also want to wipe data for Download Manager.

    Once wiped, restart your device and then reattempt the installation or update. This may require reentering your login information. Here’s a step-by-step rundown (the process may vary slightly depending on your device and Android version):

    First, go to Settings. Then navigate to Apps and find the tab for All. (On Android 9 Pie, choose Apps & notifications > See all X apps.)

    Here, choose Google Play Store. Select Force Stop, which will kill the app’s process. After this, tap Storage to get more options. On the resulting screen, tap Clear Cache to remove temporary data and hopefully fix the problem.

    If it doesn’t, you can try Clear Data. This also wipes the cache, but essentially resets the app to its original form. This means you may need to log back in and configure preferences again.

    If the above process doesn’t fix your issue, try repeating it for Google Play services, Google Services Framework, and Download Manager. Note that you’ll need to tap the three-dot Menu button at the top-right of the All apps screen and toggle Show system to see the latter two entries.

    Let me know..

  • Fsh_Fsh_ Posts: 4
    Hi @Sukanta_Biswas,

    I've tried everything you said, but it didn't fix the issue :'(
    What else could I try?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Leaderboard

This Week's Leaders